반응형
문제
철수네 마을에는 갑자기 전염병이 유행하기 시작하였다.
이 전염병은 전염이 매우 강해서, 이웃한 마을끼리는 전염되는 것을 피할 수 없다.
철수네 마을은 1번부터 N번까지 번호가 매겨져 있다.
철수네 마을의 구조는 꽤나 복잡한데, i번 마을에서 출발하면 i * 2 번 마을에 갈 수 있고,
또한 i / 3(i를 3으로 나눈 몫) 번째 마을에도 갈 수 있다. 전염병은 사람에 의하여 옮는 것으로 알려져 있다.
따라서 i번 마을에 전염병이 돌게 되면, i * 2 번 마을과 i / 3(i를 3으로 나눈 몫) 번 마을 역시 전염병이 돌게 된다.
K번 마을이 가장 처음으로 전염병이 돌기 시작했을 때, 전염병이 돌지 않는 마을의 개수를 구하는 프로그램을 작성하시오.
입력
첫째 줄에 전체 마을의 개수 N과, 처음으로 전염병이 돌기 시작한 마을 번호 K가 주어진다. ( 1 ≤ N, K ≤ 100,000 )
출력
전염병이 돌지 않는 마을의 개수를 출력한다.
입력 예시
10 3
출력 예시
4
코드
Java
import java.util.Scanner;
public class Main {
static class Queue {
private final int MAX = 100000;
private int front = 0;
private int rear = 0;
private int size = 0;
private int numElements = 0;
private int[] arr = new int[MAX];
public Queue(int size) {
this.create(size);
}
public Queue() {
this.create(10);
}
public void create(int size) {
this.size = size;
this.front = 0;
this.rear = 0;
}
public void push(int number) {
if (size <= numElements) {
System.out.println("Overflow");
} else {
arr[rear] = number;
rear = (rear + 1) % MAX;
numElements++;
}
}
public void pop() {
if (numElements == 0) {
System.out.println("Underflow");
} else {
arr[front] = 0;
front = (front + 1) % MAX;
numElements--;
}
}
public int front() {
if (numElements == 0) {
return -1;
} else {
return arr[front];
}
}
public int size() {
return numElements;
}
}
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
int vilSize = scan.nextInt();
Queue q = new Queue(vilSize);
int[] results = new int[vilSize];
int initHouse = scan.nextInt();
q.push(initHouse);
while(q.size() > 0) {
int curHouse = q.front();
q.pop();
if (curHouse > 0 && curHouse <= vilSize && results[curHouse - 1] != 1) {
results[curHouse - 1] = 1;
q.push(curHouse * 2);
q.push(curHouse / 3);
}
}
int safeCnt = 0;
for (int r : results) if (r != 1) safeCnt++;
System.out.println(safeCnt);
}
}
반응형